[Moims-sc] [MOIMS/SM&C] CCSDS 524.3-B-2: Document updates regarding raised conditions
Elmar Brendel
Elmar.Brendel at esa.int
Wed Oct 28 13:35:53 EDT 2026
Thanks, Stefan!
I followed your suggestion. In fact, "RFC 9110 / STD97" is already part of our book's "References" document list (as "[2]") . So, I simply replaced the 'placeholder' with this bookmark.
With this change, I consider the updates to the 524.3-B-2 book as completed. All raised 'conditions' have been addressed now.
Best regards,
Elmar
From: Stefan.Gaertner at dlr.de <Stefan.Gaertner at dlr.de>
Sent: Tuesday, October 27, 2026 18:03
To: Elmar Brendel <Elmar.Brendel at esa.int>; moims-sc at mailman.ccsds.org
Subject: RE: [MOIMS/SM&C] CCSDS 524.3-B-2: Document updates regarding raised conditions
Hi Elmar,
regarding the reference for HTTP authentication: I'd refer to section 11 of RFC 9110. This is the up-to-date standard. RFC 7235 is outdated, and RFC 7617 is just one of many possible schemes (which is also referenced by RFC 9110).
Cheers,
Stefan
From: MOIMS-SC <moims-sc-bounces at mailman.ccsds.org<mailto:moims-sc-bounces at mailman.ccsds.org>> On Behalf Of Elmar Brendel via MOIMS-SC
Sent: Dienstag, 27. Oktober 2026 17:49
To: moims-sc at mailman.ccsds.org<mailto:moims-sc at mailman.ccsds.org>
Subject: [Moims-sc] [MOIMS/SM&C] CCSDS 524.3-B-2: Document updates regarding raised conditions
Dear all,
I almost completed the document updates (as discussed during the fall meeting) for the 524.3-B-2 HTTP/XML binding book (aka. "524.3-P-1.1").
Quick summary/reminder:
* The technical editor provided us the word version of the document that has been reviewed and for which the conditions have been raised.
* I uploaded it to CWE: [?docx icon] 524x3b2_ MAL_HTTP_XML_revE.docx<https://spacecomm.sharepoint.com/:w:/r/sites/MOIMS/Shared%20Documents/MOIMS-SMandC/Draft%20Documents/CCSDS%20524.3-B%20-%20MO%20MAL%20Binding%20to%20HTTP%20Transport%20and%20XML%20Encoding/524.3-B-2/524x3b2_%20MAL_HTTP_XML_revE.docx?d=w04adef5f14e243a9acf5bf7c8e97c1ac&csf=1&web=1&e=0qKPUh>
* Then enabled track-changes and performed the discussed and agreed updates
* Additionally, I added a comment as "label" to each change to indicate to which condition it belongs
Once you all agree, I would "accept all changes" + "stop tracking" to have the final word document.
____
There is one issue left. It is related to "Condition 4: Section B1.3.3 - Please supply proper reference number for text that reads "...provide authentication information (reference)...""
And in fact, in Section B1.3.3 there is just a placeholder "(reference)" that was not populated yet. When analysing further, I realized we're not missing a document internal reference number, but rather and additional external document (?!). I believe the original intend was to find a document that explains the authentication mechanisms of http. For context, see the corresponding text excerpt from the book:
"HTTP provides a general framework for access control and authentication, via an extensible set of challenge-response authentication schemes, which can be used by a server to challenge a client request and by a client to provide authentication information (reference ). It is possible to use this mechanism for authentication, but that is not specified here."
We could add further documents to our reference list like:
* "RFC 7235: Hypertext Transfer Protocol (HTTP/1.1): Authentication"
* "RFC 7617: The Basic HTTP Authentication Scheme"
* ...?
but I am not an expert here and wonder if you have better suggestions. We could also (contrary to our initial response to the reviewer) just remove the placeholder and do not provide any reference at all.
Please let me know what you think.
Thanks,
Elmar
This message is intended only for the recipient(s) named above. It may contain proprietary information and/or protected content. Any unauthorised disclosure, use, retention or dissemination is prohibited. If you have received this e-mail in error, please notify the sender immediately. ESA applies appropriate organisational measures to protect personal data, in case of data privacy queries, please contact the ESA Data Protection Officer (dpo at esa.int<mailto:dpo at esa.int>).
This message is intended only for the recipient(s) named above. It may contain proprietary information and/or protected content. Any unauthorised disclosure, use, retention or dissemination is prohibited. If you have received this e-mail in error, please notify the sender immediately. ESA applies appropriate organisational measures to protect personal data, in case of data privacy queries, please contact the ESA Data Protection Officer (dpo at esa.int).
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.ccsds.org/pipermail/moims-sc/attachments/20261028/48d90196/attachment-0001.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.png
Type: image/png
Size: 559 bytes
Desc: image001.png
URL: <http://mailman.ccsds.org/pipermail/moims-sc/attachments/20261028/48d90196/attachment-0001.png>
More information about the MOIMS-SC
mailing list