[Ccsds-omg-liaison] Using AggregateParameterTypes

Overeem, David T david.t.overeem at boeing.com
Sat Jun 9 10:45:21 EDT 2012

Hi again folks.  I ran into another interesting issue when using the TelemetryMetaData/AggregateParameterType element and trying to apply the shortDescription to my structure attributes.  See fragment example below:

A structure type:

<AggregateParameterType name="MYSTRUCTURENAME_TMType">
                                <Member typeRef=" MYSTRUCTURENAME -ATTRIBUTE1_TMType" name="ATTRIBUTE1"/>
                                <Member typeRef=" MYSTRUCTURENAME -ATTRIBUTE2_TMType" name="ATTRIBUTE2"/>

Since I have already aligned the attributes in the type, it seems that in the later ParameterSet, I should define only the structure itself:

<Parameter name="MYSTRUCTURENAME" parameterTypeRef="MYSTRUCTURENAME_TMType" shortDescription="Contains the foo states or something">
                <ParameterProperties dataSource="telemetered" readOnly="true"/>

In this approach, I have now lost the ability to create a shortDescription for each of the structure members.  I realize that shortDescription can be placed in the individual *ParameterType elements for each attribute and this may need to be the answer.  Some have expressed a preference for using shortDescription within the Parameter element instead.  I might propose that we clarify this - or perhaps add shortDescription and initialValue to MemberList/Member to compensate for not having a Parameter element for each of the structure attributes.  Another possible approach exists where one could define it "C" style and specify <Parameter name="MYSTRUCTURENAME.ATTRIBUTE1" for the attributes, however the period is not allowable in the name.  Yet another approach has been suggested by Harris to use the SystemName element within the Parameter element.  In that approach, I appear (correct me if I am out of whack) to lose the separate namespace that a C structure would otherwise provide.

Another minor note - it seems like the typeRef in the Member element might be better name parameterTypeRef to be consistent with other locations where ParameterTypes are referenced?

Thoughts anyone?  I am sure I did not summarize this as good as I could have.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.ccsds.org/pipermail/ccsds-omg-liaison/attachments/20120609/07dc83fe/attachment.htm

More information about the Ccsds-omg-liaison mailing list